topbanner.gif
Login
Username

Password




Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
Shoutbox
You must login to post a message.

11/26/2020 6:37 AM
Everyone have a super Thanksgiving and may all your roasts turn out stellar woohoo

11/25/2020 4:20 PM
Howdy 1st CH and welcome to HR forum! Be sure to read in the forums to see if anything covers the topic and please post away in drum roaster forums Welcome

11/25/2020 3:35 PM
Hey everyone! I am new to the home roasters forum. Mainly here to read and learn! I’d also love to get advice about modifying my roaster (a Huky 500)

11/10/2020 5:29 PM
Welcome MJ, post away! Cheers

11/08/2020 6:05 PM
Hello All, New here, started with an air popper, now using fresh roast 800. I'm here to learn and connect with others Thank you

Users Online
Guests Online: 13

Members Online: 0

Total Members: 6,839
Newest Member: artifex
In Memory Of Ginny
Donations

Latest Donations
Anonymous - 5.00
Anonymous - 5.00
renatoa - 2.00
JitterzZ - 2.01
renatoa - 2.00

View Thread

Who is here? 1 guest(s)
 Print Thread
Artisan / Hottop /macbook
dfk53
NEED HELP!!!! Can anyone give me some insight on what is wrong? setup Artisan exactly as in manual have no control at all I don"t think it is even seeing my Mac, temp reads 32,just will not connect
dfk53
Hours of frustration only to find out the USB Cable that came with the roaster was BAD
allenb
Glad to hear it's an easy fix. Hopefully the hours spent helped you get more acquainted with the inner workings of Artisan and not totally wasted time!

Allen
1/2 lb and 1 lb drum, Siemens Sirocco fluidbed, presspot, chemex, cajun biggin brewer from the backwoods of Louisiana
Chops
I am having an issue with my Hottop -2K+ connecting to my MacBook Pro. It was working up until about 2 weeks ago. I had updated my OS. Then downloaded the latest version of Artisan v 2.4.2 and now they don't connect. I tried removing Artisan and restarting and re-downloading. Still no connection. I am using the FT230X UART.

MAC OS Catalina v10.15.7
Artisan v 2.4.2
Mac Book mid 2015

If anyone can help troubleshoot, that would be great. I just got a new bag of beans and am ready to heat them up and try them but no roaster. Shock
MaKoMo
There is no known issue with that combination. I just tested Artisan v2.4.2 under macOS 10.15.7 with my Hottop 2k+ and it worked flawless. Only the previous release v2.4.0 is known to break communication with the Hottop. Your issue must be related to the FTDI driver (you should never install an extra FTDI driver as you might run into driver conflicts with the one that is included in all newer macOS systems!) or a wrong serial port selection under Config >> Ports.
allenb
Marko, thanks for your continued help and support for our Artisan/hottop users! I know you are a very busy guy with all the work you pour into Artisan. Much appreciated. ThumbsUp
1/2 lb and 1 lb drum, Siemens Sirocco fluidbed, presspot, chemex, cajun biggin brewer from the backwoods of Louisiana
MaKoMo

Quote

MaKoMo wrote:

There is no known issue with that combination. I just tested Artisan v2.4.2 under macOS 10.15.7 with my Hottop 2k+ and it worked flawless. Only the previous release v2.4.0 is known to break communication with the Hottop. Your issue must be related to the FTDI driver (you should never install an extra FTDI driver as you might run into driver conflicts with the one that is included in all newer macOS systems!) or a wrong serial port selection under Config >> Ports.


I was wrong. Another issue related to Apple app signing and parallel processing was found in v2.4.2 that broke communication under some macOS 10.15 systems. I found a fix and uploaded a new build 3 of v2.4.2 to Github. Sorry for the confusion.
mtroaster
Hey Everyone -
I have researched this topic extensively with no help connecting my Mac / Artisan to my new Hottop 2k+.

Artisan 2.4.2 (have tried many others with no luck)
MacBook Pro 2018 (all new usb-c ports) (tried multiple cords)
Mac 10.15.7

I assume, as mentioned, it's with the serial port as it never appears to talk to the computer at all, however, have been unable to figure it out. (see attachment -- after 'config' -> 'hottop' -> then press 'On' -- that message displays."Serial Exception: Unable to open serial port')

Appreciate any help !
mtroaster attached the following image:
screen_shot_2020-11-06_at_35442_pm.png

Edited by mtroaster on 11/06/2020 5:56 PM
JackH
You tried Build 3 of Artisan 2.4.2 that MaKoMo mentioned?
I am not familiar with Mac, is there a way to see connected devices similar to the device manager in windows?

You will need to know if the mac sees the device when it is plugged in.
Edited by JackH on 11/12/2020 6:01 PM
---Jack

KKTO Roaster.
Jump to Forum:

Similar Threads

Thread Forum Replies Last Post
Spontaneous Exceptions in Artisan with TC4+ Dataloggers/Controllers/Rate of Rise Meters 9 11/24/2020 1:52 AM
First Artisan Roast Roasting Profiles 11 10/24/2020 10:56 AM
Using a TC4 with Artisan Roaster Scope Dataloggers/Controllers/Rate of Rise Meters 10 09/24/2020 12:30 PM
Hottop 2k+ Light Roast Profile HotTop Roaster 9 09/21/2020 3:07 PM
Troubleshooting Hottop with TC4 +HTC fan control HotTop Roaster 1 09/20/2020 12:23 PM
Homeroasters Association Logo, and all Content, Images, and Icons © 2005-2016 Homeroasters Association - Logos are the property of their respective owners.
Powered by PHP-Fusion copyright © 2002 - 2020 by Nick Jones.
Released as free software without warranties under GNU Affero GPL v3.
Designed with by NetriX