topbanner.gif
Login
Username

Password




Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
Shoutbox
You must login to post a message.

12/02/2021 6:47 AM
tahoeguy and sanakashyap220, coffee drink

12/01/2021 12:48 PM
Hey Ren, thanks for checking all the newcomers in!. You beat me to it most of the time but I am checking often. Grin

12/01/2021 6:16 AM
PGS_QLD, welcome !

11/29/2021 9:33 AM
Welcome, Andyc, coffeeswings and chuckster!

11/25/2021 1:17 AM
RJ30, JackedUp and CapnWhidbey, Welcome !

In Memory Of Ginny
Donations

Latest Donations
JackH - 25.00
snwcmpr - 10.00
Anonymous - 2.00
Anonymous - 5.00
Anonymous - 5.00
Users Online
Guests Online: 11

Members Online: 0

Total Members: 7,369
Newest Member: tahoeguy

View Thread

Who is here? 1 guest(s)
 Print Thread
Gene Cafe question
DaveG
best post




I haven't been around in a while, so hello! I've had my Gene Cafe for about 5 years now and I've replaced two heaters. No problem, did it myself. Currently my GC is not getting to 482, stalling around 365. It sounds like tthe thermostat is kicking it off and on like I've set it to 365. Has anyone else had a similar problem. I might be all wet on this one and it's just that it needs another heater unit. Any help is appreciated on this one.
Is there a thermostat that you ever replace in the GC?
Thanks!
Edited by ginny on 11/02/2012 8:46 PM
Yama & Gene cafe
 
John Despres
Hiya, Dave!

Sounds like perhaps your air flow may be impeded.

How often do you roast?

Two things to check -

1, Is your chaff collector clean? If you don't clean it regularly, the internal screen may be clogged. Take it apart and scrub it with some Simple Green.

2, The screen over the intake fan may be clogged. Just vacuum that. I've removed mine altogether.

There are two sensors and they are noted here. If you've replaced your heater twice, you've replaced one of them twice already, providing you bought the whole assembly.

https://docs.goog...66gvz529c3 Click through the document to the last page - Page 23

It's possible the exhaust sensor is damaged, but I doubt it...

John
Respect the bean.
John Despres
Fresh Roast 8, Gene Cafe, JYTT 1k, Quest M3, Mazzer Mini, Technivorm, various size presses and many more brewers.
 
ginny
Hi David:

I would agree with John; clean out the scum build up. It is amazing what you need to clean you simply don't see...

let us know because we clearly will offer other options...

rockon

thanks for coming by and your question is a really good one.

-g
 
DaveG
Thanks all! I'll do that right away.
Yama & Gene cafe
 
DaveG
Ok, this will defy logic, but here it is.
I thooroughly cleaned the chafe collector, vacuumed the bottom of the unit, cleaned the drum, this morning. Started roasting about 15 min. ago and noticed the same problem. GC spent 12 min. at 300, moved the temp to 482, it stalss at 460 and I hear that sound like the thermostat is keeping it from going higher. I get frustrated and tap, tap with my finger on the temp button which immediately makes me feel very stupid because it goes into cool-down. Not knowing what elase to do I unplug the GC.
When I plug it back in and set it on 482 it ramps up to 482 like a shot and all is good. Unbelievable huh? We'll see what happens next batch..
Yama & Gene cafe
 
gene
Sorry about the quote marks. I do exactly like Ginny says. Insert the quote, highlight it, and press the quote icon. Sorry, Its me I'm sure.

Dave said

Quote

I get frustrated and tap, tap with my finger on the temp button which immediately makes me feel very stupid because it goes into cool-down. Not knowing what elase to do I unplug the GC.


Dave mine does the same thing. Cruising along just before first crack somewhere around 10-11 minute mark, showing 433 or whatever and temp plummets. Couple small taps on top of GC on right side above heating element and it spurts back to correct temp.

Good to see mine is "normal".
thanks
 
gene
Hey Thanks Ginny. First time its ever worked for me.

Quote

Sorry about the quote marks. I do exactly like Ginny says. Insert the quote, highlight it, and press the quote icon. Sorry, Its me I'm sure.
 
ginny
gene,

ya did great, once you do it once or twice it's very easy. if you select your text first
simply click the quote and drop it in...

any other things like that come up for you just shout out to one of us and we will get ya fixed up...

Roflmao

ginny
 
Jump to Forum:

Similar Threads

Thread Forum Replies Last Post
Opinions requested on the Gene Cafe CBR-101 Gene Cafe Roaster 3 10/21/2021 9:56 AM
Gene Cafe Artisan profile Gene Cafe Roaster 2 10/09/2021 6:58 AM
Question about TC4 ambient temperature/cold junction MCP3424/MCP9800 Dataloggers/Controllers/Rate of Rise Meters 5 03/27/2021 9:28 AM
Behmor 1600 question Roasting Coffee 11 03/15/2021 12:32 PM
Looking to upgrade Gene Cafe WHAT SHOULD I BUY OR MAKE 7 09/24/2020 3:05 PM
Homeroasters Association Logo, and all Content, Images, and Icons © 2005-2016 Homeroasters Association - Logos are the property of their respective owners.
Powered by PHP-Fusion Copyright © 2021 PHP-Fusion Inc
Released as free software without warranties under GNU Affero GPL v3
Designed with by NetriX