topbanner.gif
Login
Username

Password




Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
Shoutbox
You must login to post a message.

09/28/2020 9:48 AM
Working on site improvements, bare with me. smoking

09/28/2020 8:58 AM
Where are the old themes ?!!! Shock

09/28/2020 12:46 AM
Made some changes, shoutbox was working without verification.

09/27/2020 2:53 PM
A lot of shoutbox spam attacks lately. roar

08/28/2020 7:15 PM
I have updated my signature and added links to the KKTO roaster build

Users Online
Guests Online: 3

Members Online: 0

Total Members: 6,749
Newest Member: Ivanwrowl
In Memory Of Ginny
Donations

Latest Donations
Anonymous - 5.00
Anonymous - 5.00
renatoa - 2.00
JitterzZ - 2.01
renatoa - 2.00

View Thread

Who is here? 1 guest(s)
 Print Thread
TC4 with aArtisanQ_PID
Will2
for example, file "commands.txt"
in directory "aArtisanQ_PID".
Viliam
James211
Ok, so I confirmed the command is OT1,{} for the power slider. However, when I put that into the serial command in the sliders, the duty reacts for a second, then goes back to zero. If I create a button, and I use OT1,50 which according to the commands should set the duty to 50%, I get a 50% reading for a split second, but then back to zero.

Do you think this is an Artisan issue or a TC4 firmware issue?
greencardigan
I don't recall your setup but I have a few questions that may help sort this out.

Do you have potentiometers connected to your TC4 analogue inputs? If you are not using them you should disable the analogue input feature in the code by commenting out the two #define ANALOGUE lines in the user.h file. If it's not disabled, the TC4 will read the open input and get random readings which can keep changing the outputs.

Did you program your TC4 yourself?
James211
Man, I think I screwed myserlf, I updated the software, now I no longer have any control, I get temp readings and thats it, no more PID function.

I tried to reinstall and now I'm getting a ton of errors, I'm not sure whats going on here.

I'm using a Quest M3 with a TC4 shield on an Arduino Uno and Artisan 0.9.9
greencardigan
What error are you getting when programming?

What version of the code are you trying to program?

You need to check the options in user.h carefully to ensure it functions properly.
James211
I'm trying to program aArtisanQ_PID6.2

It won't let me copy and paste, but its a bunch of Warning: extra tokens at end of #else directive

And java access errors

and lastly, I'm getting a low memory error

I did go through the options quite carefully, including the Analog inputs, they are all commented out.

Just to be clear: I'm copying the folders inside the Library folder into the Arduino Library folder. Then I'm opening the Artisan sketch and, I verify and upload. I get the errors on both the verification and the upload.
Edited by James211 on 12/21/2016 6:10 PM
greencardigan
I get those extra token errors and the low memory warning as well. That shouldn't affect the operation of the code. If you're getting temp readings it sounds like the sketch was programmed successfully.

PID;ON command should activate the PID.

You could try connecting with the arduino serial monitor and test the operation that way by sending commands.

Maybe attach your user.h file so I can review? You might have to change the filename to get it to upload here.
James211
Ok, here you go. I'm not sure whats going on...its very frustrating but I really appreciate your help.

Also, at one point I was able to get the duty to register on one of the Artisan LCD screens but I can no longer get that either.

Last question, did any of the pinouts change for OT1? I see in User.h it lists OT1 as being pin 9 I believe.
James211 attached the following file:
user.zip [2.83kB / 151 Downloads]
James211
Also, I get nothing when using serial monitor....no response of any kind.

Also, I've tried this on two PC's and two Mac's, all running Artisan 0.9.9 and I get the exact same results.
Edited by James211 on 12/21/2016 8:10 PM
James211
RESOLVED! I had one line that I missed that hadn't been commented out.

Power slider still doesn't work though. But I feel like I just went through the ghost of christmas past here...whew! SO grateful!
greencardigan
Excellent! Just saw your reply just when i was ready to post the following:

Try uncommenting the //#define ROR_CHAN 0 line. Not sure if that make any difference but won't hurt to have it active.

I can't see any other issues in your user.h file.

Pin 9 has been the default OT1 pin for a long time now.

A few more thoughts/suggestions/questions.

1. What version were you running previously? There has been a few changes since version 5.x.

2. User.h has this option: #define HTR_CUTOFF_FAN_VAL xx
This tells it to set OT1 power to zero if the OT2 duty is below xx which will be the case on boot up.

3. What TC4 port do you have your zero cross detecter connected to?

4. Try this in arduino serial monitor.
- Set baud rate to 19200
- Set line ending to NL
- send READ command. TC4 should respond with ambient, ch1, ch2 temps
- send PID;ON command
- send READ command again. TC4 should respond with ambient, ch1, ch2 temps and followed by heater duty, fan duty and PID set variable
- send OT2;50 to set fan duty to 50%
- send OT1;50 to set heater duty to 50%
- send READ command again to see if OT2 and OT1 commands worked and values are returned.
greencardigan

Quote

James211 wrote:
I had one line that I missed that hadn't been commented out.

Which line was this?
James211
Well, it was a few things. I reached out Jim G and he mentioned 6.2 required a ZCD, but then I realized that the actual version I was using was 6.2.2, the release you posted within the last few hours. He mentioned the PWM lines I needed to comment out and it was fixed. Team effort in the end. Thank you all. Still trying to figure out the power slider though. Jim is walking me through a few things to resolve, I'll post when finished.
greencardigan
Thanks for the info, I assumed you were using 6.2 as the user.h file you sent was not the 6.2.2 version.

Jim and I have been making a few updates lately to cater for a few different hardware variations. 6.2.2 hasn't been 'released' as the latest version yet, but you shouldn't have issues with it.

Interesting that the sliders are not working still. Does the TC4 duty change now when you set up buttons in Artisan with commands? Or when sending commands through the arduino serial terminal?
James211
Still no luck with sliders or buttons. Jim asked me try a few different things and nothing seems to work. I get a duty reading for about a second and then back to zero.

As for serial, I'm not sure if I'm missing something, but here's what I'm doing. I open Arduino Serial Monitor, I type in say "OT1,30" and I get no response and I see no effect in Artisan. Can the TC4 be connected to both Artisan and Arduino at the same time? I didn't think that was possible. Let me know if I'm doing something wrong.

Thank you.
Will2

Quote

Will2 wrote:

... Blower, therefore no heating, does not work when ZCD connected to I/O3, only to I/O2.


I think the problem is this.
I have at version 6.2 ZCD connected to I/O2.
I was unable to ever put into operation with ZCD in I/O3.
Is connected pin + 5V ZCD´s to power?
Viliam
Will2
Now it is seen in user_h that ZCD is connected to I/O2, the problem will be different.
Question remains: pin +5V.
Viliam
greencardigan
Try putting a jumper across pins 2 and 3 of the analogue input on your TC4. Do this for both ANLG1 and ANLG2 ports.

You can't have the serial monitor connected at the same time as Artisan. Can you confirm what happens in serial monitor when you follow the steps I posted a few posts back?
BenKeith
I have a question using Q_PID 6.2 with the TC4 in a stand alone configuration, no computer hooked to it.
What is suppose to start the roaster/program? So far, the only way I can start if is by turning the blower pot back some and then back to 100%.
Also, how do you select between profile 1 and profile 2?

I am giving my soon a Livia 90 and building him a 250 gram air roaster so he can roast fresh beans for espresso. I'm setting the roaster up so no computer is required, all he has to do is dump 150-250 grams of beans in it, press a button (right now, turn the pot) and dump the roasted beans out when finished. I have it set up and working great with profile 1 dialed in for a good roast curve. I'm using a second TC4 and the computer to monitor/chart the roast curve. I thought I would also set up profile 2, but changing profiles does not seem to be an option in the stand alone configuration.

I also had the Android Blue Tooth setup on it and thought about setting it up, but that kept causing problems when I had to make changes with the computer. Before I realized that was the problem, I actually swapped out the ATMEGA328P where I thought it had gone belly up because it kept giving me those stack errors you get when the boot loader is corrupted. That was also with a button I could hold to disconnect the TX/RX that's supposed to be opened when transferring data, so I pulled the Bluetooth out.
Edited by BenKeith on 02/06/2017 10:58 PM
Will2
Hi Ben,
watch this video:
https://www.youtube.com/watch?v=kCiBQ...CiBQdRgLR8
roasting starting to press SW2 (reset time), but in fact begins roasting after the fan is running.
Change the roasting profile was possible when I would pressed the SW1 - first button from right (at time 00:17).
in the video is a lot of things wrong, do not take the example of all.
Viliam
Jump to Forum:

Similar Threads

Thread Forum Replies Last Post
Loading aArtisanQ_PID in Arduino Dataloggers/Controllers/Rate of Rise Meters 14 05/28/2018 8:32 PM
Help with aArtisanQ_PID Specifying Temps Dataloggers/Controllers/Rate of Rise Meters 7 08/03/2017 7:05 PM
TC4 aArtisanQ_PID or Standard Library Dataloggers/Controllers/Rate of Rise Meters 45 01/24/2016 12:17 PM
aArtisanQ_PID 5,3 with TC4 display problem Dataloggers/Controllers/Rate of Rise Meters 14 01/23/2016 11:15 AM
AartisanQ_PID 5.3 with TC4 and RoastLogger Dataloggers/Controllers/Rate of Rise Meters 6 12/14/2015 10:52 AM
Homeroasters Association Logo, and all Content, Images, and Icons © 2005-2016 Homeroasters Association - Logos are the property of their respective owners.
Powered by PHP-Fusion copyright © 2002 - 2020 by Nick Jones.
Released as free software without warranties under GNU Affero GPL v3.
Designed with by NetriX