topbanner.gif
Login
Username

Password




Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
Shoutbox
You must login to post a message.

renatoa
05/23/2022 10:46 AM
abiy welcome cup

renatoa
05/18/2022 6:13 AM
gnosis coffee roasters and Terry Hauser, welcome !

allenb
05/15/2022 7:00 PM
lsawade welcome Welcome

renatoa
05/15/2022 9:13 AM
Welcome, Pinofly and Alex008

allenb
05/12/2022 7:47 PM
CafficitoeTim and pmf2000 Welcome! Welcome

In Memory Of Ginny
Donations

Latest Donations
dmccallum - 10.00
JackH - 25.00
snwcmpr - 10.00
Anonymous - 2.00
Anonymous - 5.00
Users Online
Guests Online: 7

Members Online: 0

Total Members: 7,580
Newest Member: abiy

View Thread

Who is here? 1 guest(s)
 Print Thread
Am I doing something stupid TC4C+Artisan
MaKoMo
I am not a Windows guy. So I wrote "some tool" as I guess some tool might exist to do that job. Only the registry and the App folder are touched by Artisan.

Btw. there is no need to roll back to 0.6. That code did not change between versions from 0.5 to 0.8. A quite large number of users (incl. myself) is using (or have been using) all of those version with aArtisan in C and/or F without any problems. So I am pretty sure that this is not a software issue on TC4 nor Artisan side.
 
therabidweasel
Based on your comments I went ahead killed anything in the registry that said artisan and installed 0.8.0...I have the same issue. I thought that maybe plugging get the PC into the same outlet might be a problem, but removing that didn't help. I can literally touch my breaker box and the roaster at the same time, so I didn't figure it would be a problem.

One intriguing thing happened and that was when the hot top cooled down before restarting, it did not catch the 168 mark and so the clock didn't start running. When it hit 425 it was still waiting to start and therefore didn't shut down. I pushed it up until the RTD said 440 (artisan BT=344) and shut it down. I am completely clueless now. I cannot forget about the RTD, because it is shutting the roaster down while Artisan is still 100 degrees below my drop temperature. Maybe my board is going out, but that corresponding to changing the computer just seems improbable. I'm lost.
 
therabidweasel
For whatever reason it is also not displaying the default buttons fo 1C start and end etc...even though those boxes are checked.
 
MaKoMo
My last guess is that you have a problem with your Windows registry. Artisan stores its state, including the one which event buttons to show and the temperature mode (C/F), in this registry. If this does not work reliable on read or write, Artisan might act in quite funny ways. There must be a tool to check/validate/fix that registry.

If you use the "Factory Defaults" menu item, Artisan will ignore the registry settings on next start and use its default values. On quite of Artisan the actual settings are stored back to the registry.

Problems with any other software on that machine?
 
therabidweasel
Gentlemen, my problem is solved. Marko, your assessment made perfect sense to me. So much so that I formatted the hdd and reinstalled windows, service packs, and drivers...twice. I did have some problem involving AMD processor and Intel power management drivers that was somehow being masked until the reinstall. I had also manually removed a ton of Adobe software directly from the registry of this machine 5-6 years ago before I stored it. When I finally got it all back up and running it was storing my settings (in showing the buttons etc) but I still had the same problem with the measurements tracking my Celsius meter.

The above made me reconsider the hardware change to a desktop. I never ran my laptop off a supply, always off the battery. I have ungrounded TCs, but they are shielded. Sure enough I fixed the problem by tying the roaster chassis to USB ground. Oh the humiliation! Weeks I've been trying to fix this!

Gentlmen, i express to you my deepest thanks and apologies. I had thought about this often when i was running floating on the laptop. However, in my haste to get back up and running before my travels I forgot this possibility. The fact that my measurements tracked a separate meter was a red hearing, once again proving correlation is not necessary causation. Should i meet either of you in person in the future, i owe you a beer. Marko, you can also kick me square in the giblets if you want. I deserve it.

I appreciate everyone's help. Hopefully my shame will help other people in the future. Again, Marko and Jim, I am indebted to you.
 
therabidweasel
Hopefully not digging the hole any deeper, but I never thought there was a problem with the Artisan software per se. My theory was maybe the units switch was accomplished by toggling a state without maybe checking the current state or some other mechanism that might allow it to get out of sync in rare instances. I did not mean to cast aspersions on the software, which is freaking awesome and has better support than most paid software. It reminds me of a quote of Ben Franklin that was something like: teach a man to shave and keep his razor in order and he'll have a lifetime enjoying shaving on his on schedule and to his liking and benefit. Thanks for helping all of us "shave" Artisan team.

I'm wondering about the results I was getting by querying through the Arduino serial monitor. I think maybe that was because by shutting artisan off to open the port I was also shutting the heater off. I know the heater current was affecting the grounding because I can see it in my curves. I don't really understand the mechanism though because the PC and roaster were on separate circuits and the roaster chassis isn't even connected to anything. . .not to mention I have ungrounded friggin probes. I'd welcome any theories because I am missing something there.
 
JimG
I can't pinpoint a cause-and-effect relationship. But I know from experience that there is a high correlation between shielded probes and problems with the TC4 hardware.

The chip that reads the thermocouple signal is pretty sensitive -- remember we are looking for differences measured in microvolts in a thermocouple signal that rarely gets above 10mV. Also, when set to its highest resolution mode, the input impedance of the chip is not as high as I would like it to be (a tradeoff).

So anything that messes with the potential difference between the GND plane on the TC4 board and the tip of the thermocouple can mess up your readings.

Something about the shielding on the probes seems to mess with this potential. I can't put my finger on what it is, but like I said above, there is a very high correlation between shielded probes and problems!

Jim
 
therabidweasel
Something just seems wrong about a "shield" causing problems, doesn't it? I'm glad i payed omega top dollar for them. It works now though, and it's an easy fix I reckon. It's also something to ponder over an ale 8!
 
Jump to Forum:

Similar Threads

Thread Forum Replies Last Post
Using a TC4 with Artisan Roaster Scope Dataloggers/Controllers/Rate of Rise Meters 41 05/09/2022 12:06 PM
Glitch When Using Artisan Alarms Dataloggers/Controllers/Rate of Rise Meters 6 05/07/2022 2:33 AM
Finding Artisan 1.6.1 binary for Mac ROASTING SOFTWARE APPS 3 02/26/2022 5:49 PM
Scott Rao and Browning Phase with Artisan Roasting Coffee 8 01/27/2022 7:15 PM
Fluid bed roaster cooling stage Artisan+TC4 Fluidbed Roaster 8 01/24/2022 6:36 AM
Homeroasters Association Logo, and all Content, Images, and Icons © 2005-2016 Homeroasters Association - Logos are the property of their respective owners.
Powered by PHP-Fusion Copyright © 2022 PHP-Fusion Inc
Released as free software without warranties under GNU Affero GPL v3
Designed with by NetriX