topbanner.gif
Login
Username

Password




Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
Shoutbox
You must login to post a message.

03/04/2021 9:04 PM
I have been trying Scott Rao Hario V60 pourover this week. 1:17 and blooming with 2 parts water the first 45 seconds then splitting the rest into 2 pours. A little stirring is included. We like it.

03/04/2021 11:35 AM
My brew ratio is 1:17 (exactly 59.5 g/L). That's roughly 8.5g per 5-oz cup.

02/27/2021 9:29 AM
I'm looking to hire someone to teach/help me to find the best roast profile for the 3 types of coffee that grow on my farm in nicaragua. I live in LA, but but could go anywhere in so cal with my Behmor for a roasting lesson. Please contact me if you're in

02/17/2021 7:20 PM
When your wife thinks 30 grams for a 6 cup setting is strong, you learn to drink muddy water when you are making coffee for both of you.

02/17/2021 8:32 AM
I use a rule of thumb of 60 grams per liter. 8 cups (1 liter, 32 oz) = 60 grams, 6 cups (3/4 liter, 24 oz) = 45 grams. 10 cups = 75 grams 12 cups = 90 grams

Users Online
Guests Online: 12

Members Online: 0

Total Members: 7,042
Newest Member: K666B
In Memory Of Ginny
Donations

Latest Donations
Anonymous - 5.00
Anonymous - 5.00
renatoa - 2.00
JitterzZ - 2.01
renatoa - 2.00

View Thread

Who is here? 1 guest(s)
 Print Thread
Artisan Connection to TC4C Error
drothra
Artisan 0.9.7 reports Exception: ser.ARDUINOTC4temperature(): list index out of [email protected] My ET is -1.0 and BT is -1.0.

I have an LED screen attached to the TC4C (new acquisition) that show T1 and T2 thermocouples are functioning properly - they show expected changes in temperature when I moved them from hot to cold.

The problems seems to be communicating with Artisan software. I've tried resetting the Artisan software, adjusting the baud rate to 19,200, finding the right COM port, etc.

I'm using an Amico K Type thermocouple and a generic K type Termocouple (both red/white ends) and my computer is running Windows 7 professional.

Any thoughts on this connection issue?
Anything I could provide to help diagnose?

A dedicated "Troubleshooting" area might be helpful for folks like me. It could have that title with sub-groups based on software, hardware, etc.

Thank you,

Dan
Multiple-Modified popcorn popper roasters... It's still cheaper than therapy...
I'm also working to build 1-2 pound fluidbed roaster
turtle
Welcome to HRO.

Have you been successful using another interface (meter, etc) or is this your first attempt to connect your roaster to artisan?

I am assuming you have checked that you have TC4 selected in Config > Device Assign?

Are you starting artisan with the default profile or with a preset profile?
Mick - "Drinking in life one cup at a time"
"I'd rather be roasting coffee"

Roaster 1: San Franciscan SF-1
Roaster 2: Hottop B-2K+
Roaster 3: Behmor 1600 +
Grinders: Modified Super Jolly - Forte BG (x3)
Pour over: Hario - Bee House - Chemex - Kalita - Bodum
Drip: Bunn CWTF15-1 & CW15-TC (commercials)
Espresso: Pasquini Livia 90 auto
Vacuum: Cona - Bodum
Press: Frieling - Bodum Colombia
drothra
Mick,

Thank you for the welcome to HRO... it's deep in HRO... I've gotten lost in the threads and searched for an hour before posting this question... thank you for throwing me a life preserver.

Yes, this was the first time connecting the Artisan software and the TC4C. I was pleased to get the TC4C from Jim a week ago and thought I would test it before trying to connect to roaster. Its the singular board with the build in Arduino processor.

Yes, I did select the TC4 button on the Config menu which then took me immediately to the Port selection/baud rate widow which I set for 19,200.

It was a fresh start so Artisan was in default profile... no profiles... When it would have an error I would reset it... then restart it... it would scope and then error.

Initially, when I first plugged the TC4C into the USB I had connected a single (one) thermocouple to the wrong input location... (T4 when I should have been at T1) and the Artisan software said my ET was 76 degrees but that never changed when I put the TC in ice water or near a burner on the stove...

The LED screen showed that TC4C was collecting data from the TC and tracking accurately in both TC but I just couldn't get the info into the software...

Perhaps I should wipe the software off my computer and start all over again with a fresh install with the TC on the right inputs...

I'll try that and any other ideas you suggest. Again, thank you for your note.

Sincerely,

Dan
JackH
Did the TC4C come with the aArtisan sketch installed by Jim?
What OS are you running Windows, Linux or Mac?

Make sure you are installing the latest Arduino IDE software and that you remove any older versions that might be conflicting.

I wrote a procedure that might help.

https://drive.goo...Z4Uk0/edit

It was written for an older version of Artisan but it should help you troubleshoot the problem and take you through the steps.

You can skip the part that loads the aArtisan sketch since you already have it installed from Jim.
---Jack

KKTO Roaster.
Jump to Forum:

Similar Threads

Thread Forum Replies Last Post
Using a TC4 with Artisan Roaster Scope Dataloggers/Controllers/Rate of Rise Meters 11 01/27/2021 10:56 AM
Modification of a Drum Air Fryer into an Artisan-controlled Coffee Roaster Building a Coffee Roaster 5 01/27/2021 7:09 AM
SOLVED: Artisan says: "Arduino could not set channels" Dataloggers/Controllers/Rate of Rise Meters 9 01/24/2021 2:14 AM
Arduino and Artisan Dataloggers/Controllers/Rate of Rise Meters 4 01/21/2021 1:07 PM
Artisan and Mastech 6514 Dataloggers/Controllers/Rate of Rise Meters 12 01/08/2021 2:52 AM
Homeroasters Association Logo, and all Content, Images, and Icons © 2005-2016 Homeroasters Association - Logos are the property of their respective owners.
Powered by PHP-Fusion Copyright © 2021 PHP-Fusion Inc
Released as free software without warranties under GNU Affero GPL v3
Designed with by NetriX