Print Thread
Hottop B-2K+ with Artisan
tweetr
I just purchased a brand new B-2K+ in 220v shipped directly from Taiwan and am having trouble getting it to recognize and be controlled by Artisan.

I?m running Artisan v1.0.0b1 on a Linux Ubuntu v16.04 32-bit laptop, and Artisan v1.0.0b3 on a Windows 7 64-bit laptop. I very carefully followed the configuration steps on this page: https://artisan-r...8b-2k.html

and I very carefully followed the USB connection instructions on this page: http://www.hottop...NNECT.html

The problem I have is that I never see the USB symbol on the Hottop control panel and the options available are Auto and three Manual modes, but no USB control mode.

When I connect to the Ubuntu machine I can see the UART 230 com port, and when I connect to the Win7 machine I can see the USB com port; I have it configured according to the instructions above; I have right-clicked the top right LCD so that "Super On" displays; I have ticked the ?Control? box on the configuration menu; when I click the blue ?Control? button, it turns from blue to brown. I still never see the USB symbol on the Hottop control panel. When should that USB symbol show up? When I click the Artisan ?On? button the motor does not start on the Hottop, and none of the sliders or buttons do anything on the Hottop. When I manually run a roast with all the above done I also get no data showing on the Artisan screen. ET and BT remain flat at default values.

This is true for both the Ubuntu and the Win7 machines. I tried two different brand new USB 3.0 cables, so I don?t think a bad cable could be the culprit. I read every thread I could find on Homeroasters.org relating to the Hottop with Artisan, but I can?t seem to solve my problem.

What am I doing wrong? I purchased the B-2K+ expressly for controlling roasts with Artisan, so I am frustrated!

Thanks,
Tom Stearman
 
tweetr
Okay, I have it all working now! Marko Luther at Artisan helped me out. In Ubuntu it is necessary to add my username to the "dialout" group before Ubuntu will let me communicate across the USB Com port. This was not clear in the Artisan documentation, but he sent me to this page: https://github.co...llation.md
The short version is:
In Ubuntu open a terminal window and type:

sudo adduser <username> dialout

Then it did not become effective until I logged out of my user account and logged back in! Then open a terminal window and type:

id

to verify that my username was indeed added to the "dialout" group.

After that I was able to start Artisan, right-click on the upper right LCD to enable "Super On", and click the blue "Control" button to take control of the Hottop ("Control" button then turns brown and Hottop motor starts turning.) Then click the "On" button to begin logging parameters.

I have the Win7 machine communicating too, though I'm not sure what the problem was because I went through all the configuration steps on a new Artisan installation. I suspect I just hadn't correctly right-clicked on the top right LCD to enable "Super On". That step is in the documentation, but in my view is not as clear as it should be:

Right-click the upper right LCD for "Super On", right-click again for "Super Off".

Anyway, it's all working now and I just finished two very successful Artisan-controlled roasts of a Guatemala Antigua (full city) and a Papua New Guinea PB (city).
 
Jump to Forum: