Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
You must login to post a message.

03/04/2021 9:04 PM
I have been trying Scott Rao Hario V60 pourover this week. 1:17 and blooming with 2 parts water the first 45 seconds then splitting the rest into 2 pours. A little stirring is included. We like it.

03/04/2021 11:35 AM
My brew ratio is 1:17 (exactly 59.5 g/L). That's roughly 8.5g per 5-oz cup.

02/27/2021 9:29 AM
I'm looking to hire someone to teach/help me to find the best roast profile for the 3 types of coffee that grow on my farm in nicaragua. I live in LA, but but could go anywhere in so cal with my Behmor for a roasting lesson. Please contact me if you're in

02/17/2021 7:20 PM
When your wife thinks 30 grams for a 6 cup setting is strong, you learn to drink muddy water when you are making coffee for both of you.

02/17/2021 8:32 AM
I use a rule of thumb of 60 grams per liter. 8 cups (1 liter, 32 oz) = 60 grams, 6 cups (3/4 liter, 24 oz) = 45 grams. 10 cups = 75 grams 12 cups = 90 grams

Users Online
Guests Online: 13

Members Online: 0

Total Members: 7,043
Newest Member: tigertictac
In Memory Of Ginny

Latest Donations
Anonymous - 5.00
Anonymous - 5.00
renatoa - 2.00
JitterzZ - 2.01
renatoa - 2.00

View Thread

Who is here? 1 guest(s)
 Print Thread
Loading aArtisanQ_PID in Arduino
Hi, I need details or steps for how to load aArtisanQ_PID into Arduino UNO. I have aArtisanQ_PID_6_3 folder which include "aArtisanQ_PID.ino" and other files inside the the subfolder " Libraries".
I tried to load "aArtisanQ_PID.ino" into Arduino but it shows error as attached image. if I success to do that then I will attach TC4 to Arduino.

Thank you
Husamka attached the following images:
screen_shot_2018-04-09_at_21923_pm.png screen_shot_2018-04-10_at_74518_pm.png screen_shot_2018-04-09_at_44108_pm.png

Edited by Husamka on 04/13/2018 10:24 PM

I think your libraries are in the wrong location. Should be here. Copy the folders within the Artisan Libraries into the Arduino libraries folder alongside any other libraries that are already in there.

I think part of your error message is being hidden. Try expanding the bottom section up so we can see the full error.

Also, don't forget to go through the user.h file to check all the setting and options before loading onto your arduino.
greencardigan attached the following image:
greencardigan, Thank you for help.
I received TC4 and ZCD from Viliam and the LCDapter 20x4 still in the way. Also I have Relay CWD2425, POT 10K and Jumper Wires. others are in the way.

So initially I am trying to load the aArtisanQ_PID into Arduino UNO. I just connect Arduino to the USB cable without TC4 but as I mentioned the error message appeared.

I downloaded Arduino IDE and the zip file which contain only one file as below. there is no libraries folder. I noticed you have files which is not in my aArtisanQ_PID folders.
If possible you email me "aArtisanQ_PID" full with all required files. so I can do the copy which you mentioned.
I didn't connect Arduino to TC4 and to other hardwares. can you explain which amendment shall I do to file "user.h" for this stage. or any other suggestion you may have for me.
Husamka attached the following images:
screen_shot_2018-04-14_at_114444_am.png screen_shot_2018-04-14_at_113121_am.png
there are 3 possible ways to upload aArtisanQ_PID to Arduino.

1. The method, official, as described by Brad in the previous post, is a way that JackH describes in ArduinoTC4ArtisanSetup_Doc in:
The directory libraries is in Windows here: C: \ Program Files (x86) \ Arduino \ libraries
copy directories including embedded files from the aArtisanQ_PID_6_3 libraries to this directory.
I do not use this method, I do not have the libraries installed in this location.

2.the way is similar to what I described in the post for
I use this method, I do not have libraries installed according to method 1.
But to the C: \ Users \ xxxxx \ Documents \ Arduino \ libraries \ TC4StdLibREL400 directory, I have moved all the files from the libraries directory and subdirectories (only files without directories).

3. Way totally simple, but primitive (but you do not have to have any libraries from aArtisanQ_PID according to previous methods), with mouse drag to window Arduino IDE all files from the directory and subdirectories in aArtisanQ_PID and its libraries. Then compile.

The problem is that in each of these cases you do not have to be instaled libraries to another location as described.
Viliam, Thank you for the informations and your efforts.

I am useing macOS , not Windows. just in case some of the files you sent is for Windows.

As you see in the attahced images that I did the steps as you mentioed, then I compiled. But I got error.
Husamka attached the following images:
screen_shot_2018-04-15_at_72413_pm.png screen_shot_2018-04-15_at_72241_pm_1.png

Edited by Husamka on 04/15/2018 11:38 PM


... the files you sent ...

I did not send you a file, I sent you this link:

There you have all the files, also for MacOS.
It seems to me that the only thing you did is that you just unzipped the ZIP and clicked on aArtisanQ-PID.ino, nothing else as you got advice.
I did compiling aArtisanQ_PID in Arduino but not quit sure if its correct you can see in the attached images. If this is correct then I will upload it in to Arduino. I am doing this before the wiring and connect to all other hardwares. and I don't know which changes that I have to do to file (user.h ). thanks
Husamka attached the following images:
lib.png code_file.png code_2.png
That looks fine. Don't worry about those warnings.

I did compiling and uploading and the attached error message is showed. I copied all folders inside aArtisanQ's Libraries to inside Libraries of Arduino. please advice if the list of 9 files which showed in the top is correct. the file(user.h) already as per the connections below

OT1 for Heater
OT2 for Ac fan
IO2 for ZCD

Husamka attached the following image:
You probably have the wrong com port selected. Check tools -> Port and select the correct com port your Arduino is connected on.
Thank you Brad,
You are right, I forgot to choose the port. But still not sure if the uploading is correct.
Husamka attached the following image:
'Done uploading' means it loaded successfully.

You should be able to test by using the serial monitor to send a READ command and see if it responds.
See Part 3 of Jack's tutorial
Thank you Brad for spending time to find this old file. Its really what I am looking for since April, but the name been changed since 2013. I was searching with words "loading aArtisanQ". Now I tested the board response and Artisan can read BT and ET. Thanks again.
Jump to Forum:

Similar Threads

Thread Forum Replies Last Post
TC4 with aArtisanQ_PID Dataloggers/Controllers/Rate of Rise Meters 412 03/03/2021 11:39 AM
SOLVED: Artisan says: "Arduino could not set channels" Dataloggers/Controllers/Rate of Rise Meters 9 01/24/2021 2:14 AM
Arduino and Artisan Dataloggers/Controllers/Rate of Rise Meters 4 01/21/2021 1:07 PM
Ametek Motor -Speed Control / Arduino Control??? Fluidbed Roaster 29 11/05/2020 1:32 AM
TC4+ Arduino coffee roaster shield (TC4-compatible) Dataloggers/Controllers/Rate of Rise Meters 220 10/01/2020 6:12 PM
Homeroasters Association Logo, and all Content, Images, and Icons © 2005-2016 Homeroasters Association - Logos are the property of their respective owners.
Powered by PHP-Fusion Copyright © 2021 PHP-Fusion Inc
Released as free software without warranties under GNU Affero GPL v3
Designed with by NetriX