topbanner.gif
Login
Username

Password




Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
Shoutbox
You must login to post a message.

10/21/2021 2:41 AM
muckymuck, mckinleyharris and williamjonex welcome cup

10/19/2021 6:22 AM
Welcome tarunk!

10/17/2021 12:40 PM
Ploni and nader fouad, Welcome!

10/15/2021 2:19 AM
merlot85, maycondelpiero and hoeltz, Welcome !

10/14/2021 10:06 AM
Thanks for the addition to the group. Seriously considering building a drum roaster along the lines of oldgrumpus's. Love the design and craftsmanship.

In Memory Of Ginny
Donations

Latest Donations
JackH - 25.00
snwcmpr - 10.00
Anonymous - 2.00
Anonymous - 5.00
Anonymous - 5.00
Users Online
Guests Online: 27

Members Online: 0

Total Members: 7,369
Newest Member: williamjonex

View Thread

Who is here? 1 guest(s)
 Print Thread
Windows 10 USB Device Problem: Solved.
Tavake12
Problem: Artisan Software installed property, connected to Hottop roaster, has both logged and controlled the roaster, and then, when starting a new day's roasting, i get an error from Microsoft when I try to plug in the roaster via USB:

"USB device not recognized
The last USB device you connected to
this computer malfunctioned, and
Windows does not recognize it."

Lenovo Yoga 930 with Windows 10 factory installed, Artisan 2.1.1.

The root cause was that notebook power supply was not connected. The power management setting for the USB root hub was set to allow the computer to turn off the USB root hub to save power!

What is really funky is that a USB stick plugged in immediately after unplugging the Hottop WAS recognized!

Solutions: 1: plug in the power on the notebook, or 2: go to device management, USB root hub, properties, power management, and un-check the top box (you must do this as administrator).

This situation developed because the Artisan documentation states that sometimes the curves are tweaked if a laptop is plugged in, so recommends not plugging them in.

OK, that advice was probably true 4+ years ago, but my new Hottop came with a USB cable that has emf protection, and I'm pretty sure the modern Lenovo notebook charger does not generate this type of issue.

It is, however, more convenient to use the notebook without having to plug in the charger, so disabling this setting is very helpful.

Cheers!
JackH
Thanks for reporting this, it will be useful for others who are having trouble.
---Jack

KKTO Roaster.
Jump to Forum:

Similar Threads

Thread Forum Replies Last Post
SOLVED: TC4+ fan control goes cracy Dataloggers/Controllers/Rate of Rise Meters 17 02/18/2021 5:48 PM
SOLVED: Artisan says: "Arduino could not set channels" Dataloggers/Controllers/Rate of Rise Meters 9 01/24/2021 2:14 AM
Getting Center 301 to connect to Windows 10/Artisan Dataloggers/Controllers/Rate of Rise Meters 2 11/07/2019 6:04 PM
Inner drum problem Drum Roasters 2 05/05/2019 8:11 AM
World Coffee Production Problem???? Books, Magazines, Blogs and Articles 1 01/17/2019 3:10 PM
Homeroasters Association Logo, and all Content, Images, and Icons © 2005-2016 Homeroasters Association - Logos are the property of their respective owners.
Powered by PHP-Fusion Copyright © 2021 PHP-Fusion Inc
Released as free software without warranties under GNU Affero GPL v3
Designed with by NetriX