topbanner.gif
Login
Username

Password




Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
Shoutbox
You must login to post a message.

10/17/2021 12:40 PM
Ploni and nader fouad, Welcome!

10/15/2021 2:19 AM
merlot85, maycondelpiero and hoeltz, Welcome !

10/14/2021 10:06 AM
Thanks for the addition to the group. Seriously considering building a drum roaster along the lines of oldgrumpus's. Love the design and craftsmanship.

10/14/2021 4:00 AM
Morning, ar3mia ! and... coffee drink

10/12/2021 11:55 AM
Evan Slack and CupOfJoe, Welcome !

In Memory Of Ginny
Donations

Latest Donations
JackH - 25.00
snwcmpr - 10.00
Anonymous - 2.00
Anonymous - 5.00
Anonymous - 5.00
Users Online
Guests Online: 14

Members Online: 0

Total Members: 7,362
Newest Member: nader fouad

View Thread

Who is here? 1 guest(s)
 Print Thread
MCP3424 on TC4 blowing
pjvdl
I have an interesting problem with the MCP3424 ADC chip on my TC4 board blowing up. I have now blown 6 or 7 MCP3424 chips while trying to isolate the problem, although interestingly it is only ever the MCP3424 chip that blows. The rest of the TC4 board and carrier arduino continue to operate correctly (on each occassion I have tested the I2C bus separately to confirm that the MCP9800 chip is still operational as well).

My setup is a 1kg drum roaster with:
  1. 240V resistive wire as a heater (Nichrome)
  2. 12V DC fan
  3. old 12V windscreen wiper motor as drum motor (brushed motor I think)
  4. 3 k-type thermocouples (chamber, bean mass, exhaust) connected to TC4 clone
  5. TC4 clone/Arduino with onboard control provided by 2 potentiometers and external control/monitoring via USB and Artisan

You can find more about my build at https://homeroast...ad_id=6334.

During a couple of early tests of the system I noted fluctuations in temperature readings when I turn the drum motor on or off. The motor is drawing around 4A @ 12V In a steady state, but I think it may be pulling up to 15A transient on startup. This is difficult to ascertain though, as my multimeter doesn't have the response times to see the transient currents accurately.

My working theory is that electro-magnetic interference from the heater and/or motor are causing excessive voltage in the thermocouple input, which exceeds the input rating of the MCP3424 inputs. This seems to be supported by my above observation that the temperature readings fluctuate more as the motor is turned on/off, because of the current transients that occur.

To address this, I have:
  1. confirmed I am using shielded thermocouple wires
  2. physically separated the thermocouple wires as much as possible from the motor and heater and other high voltage (240V) components and wiring
  3. designed a TC4 board that includes 100pF capacitors between each of the thermocouple inputs and ground

Having made these changes, I no longer see any temperature reading fluctuations. This seems to indicate I am not getting voltage spikes any more, but in spite of this, I have still blown a couple of MCP3424's.

At the moment the thermocouple wires run inside the chassis of the drum roaster, so they are still within 60 - 70mm of the heater and the heater. This may still be too close, so I think the next step will be to temporarily remove the wires to run them externally as a test.

Other than that, I am out of ideas.

If anyone has seen this type of issue, I would very much appreciate some suggestions for how to solve it!
Edited by pjvdl on 04/27/2021 8:35 PM
-- Paul

ECM Rocket espresso
Eureka Mignon grinder
500g BBQ rotisserie roaster
1kg drum roaster
greencardigan
I'm not sure what's causing your issue. For the TC4s I build, I use 10,000pF caps across each input and also between each input pin and ground. So 12 caps in total. No idea if this would help your issue though.
renatoa
Attached is the typical schematic of a dedicated TC amplifier circuit.
The lower part is the input filtering, good as start for virtually any TC interface ICs.

Me too I blown a circuit as above, but was a serious overvoltage, between the naked junction and the oven case, ungrounded, that also thrilled me when touching.

Electromagnetic interference are not a concern, using happily unshielded probes at 20 cm near two motors.

...
renatoa attached the following image:
ad8495_schema.jpg
mg512
I've occasionally seen the MCP3424 blow on the TC4+, and I also heard from JimG that this happened on the original TC4 sometimes as well. That said, I was never able to figure out with certainty what's causing it, as it never happened in my own tests or usage, only ever with customers. I've never seen it happen multiple times with the same customer though.

Recently I've added TVS diodes to the TC inputs on the latest version of the TC4+, which would help if users accidentally shorted a >5V signal to one of the TC inputs. I haven't seen any blown chips since that change, but it's been very recent, and it was only ever a very infrequent thing to begin with, so can't conclude anything with certainty yet.

Are you using a TC4 or TC4+? If it's a TC4+, I'd be happy to send you another one from the latest batch just to see if it makes a difference.

I would in any case also triple and quadruple check that nothing touches anything anywhere that could in turn touch anything that has more than 5 volts on it. That includes the metal shielding of the TC wires, which could easily make (even intermittent) contact with the screw terminals on the TC4/TC4+.
JackH
Are you using grounded or ungrounded probes? I seem to remember a problem in the past with grounded probes since the wires are physically attached to the inside of the probe wall. The temperature readings were very unstable. Ungrounded are electrically isolated from the sheath but are slower to respond.
---Jack

KKTO Roaster.
pjvdl
Thanks all for your input.

Attempting to respond to your suggestions.:

I have 10uF caps between the inputs and ground, but not between the inputs themselves. I think I will look at adding these just in case.

I am using ungrounded k type probes, so hopefully the grounding isn't a problem.

I was using a TC4+, but was having issues getting a new one last year, so ended up designing my own clone of the TC4.

I agree that I need to check voltages again. This remains, in my view, one of the most likely causes.

Thanks again all. Will keep you posted with progress.
-- Paul

ECM Rocket espresso
Eureka Mignon grinder
500g BBQ rotisserie roaster
1kg drum roaster
renatoa
The caps value should be 10 nF = nano, not uF = micro.
Is not about the value itself, but technology, the capacitors in the micro Farad ballpark are usually electrolytic, with internal leakages that could affect reading precision.

Ungrounded aren't slower by default, is the sheath that give the most of the measurement speed.

If you have the skills to build yourself a TC4, then you could consider an architecture change, with dedicated TC amps before the MCP DAC, as in the picture attached some posts above.
This solution is inspired (but not copied Grin) from Phidgets architecture, and based on my experience is better than original TC4 solution, as precision, stability and speed.
Not the last, is fully supported by current TC4 firmware, changes in code being minimal.
Edited by renatoa on 05/07/2021 1:26 AM
JackH

Quote

renatoa wrote:


Ungrounded aren't slower by default, is the sheath that give the most of the measurement speed.



Not according to the Omega site.

homeroasters.org/forum/attachments/probe.jpg
---Jack

KKTO Roaster.
renatoa
404 Not Found
Incomplete link it seems.

I think I found the primary source of this info:

Quote

How do I know which junction type to choose?
Sheathed thermocouple probes are available with one of three junction types: grounded, ungrounded or exposed. At the tip of a grounded junction probe, the thermocouple wires are physically attached to the inside of the probe wall. This results in good heat transfer from the outside, through the probe wall to the thermocouple junction. In an ungrounded probe, the thermocouple junction is detached from the probe wall. Response time is slower than the grounded style, but the ungrounded offers electrical isolation.


https://www.omega...uples.html

... the confusion could come from the different meanings we have for the "grounded" term, related to the sheath or to the wires. Or even to the junction itself.
I am using the grounded term as a substitute for shielded wires, in a metal mesh, not for the probe itself. Shielded wires were those who gave me headaches so far, as you already posted above.
From what I tested to date, an exposed junction has the fastest response, but is so nervous that it really needs some sort of sheath to calm down a bit the response time, else the results are useless noise.
Here is the part were we can debate about grounding... it is good or not to have junction/wires touch the sheath ? should be the sheath metal be grounded or not... etc...
Edited by renatoa on 05/07/2021 7:27 AM
Jump to Forum:

Similar Threads

Thread Forum Replies Last Post
Question about TC4 ambient temperature/cold junction MCP3424/MCP9800 Dataloggers/Controllers/Rate of Rise Meters 5 03/27/2021 9:28 AM
Sucking and Blowing Building a Coffee Roaster 22 04/08/2020 4:31 AM
Homeroasters Association Logo, and all Content, Images, and Icons © 2005-2016 Homeroasters Association - Logos are the property of their respective owners.
Powered by PHP-Fusion Copyright © 2021 PHP-Fusion Inc
Released as free software without warranties under GNU Affero GPL v3
Designed with by NetriX