Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
You must login to post a message.

12/07/2023 9:47 AM
Hi Ken, good to see you again!

12/06/2023 3:24 PM
I'm back. Sort of. I've not logged in for a while. Ken bbq

12/06/2023 1:11 AM
coffeeengineer and Ranloe, welcome cup !

12/05/2023 2:44 AM
Isdel7 and Sloppy Fingers welcome to forum

12/04/2023 11:51 AM
Ross Welcome

In Memory Of Ginny

Latest Donations
dmccallum - 10.00
JackH - 25.00
snwcmpr - 10.00
Anonymous - 2.00
Anonymous - 5.00
Users Online
Guests Online: 8

Members Online: 0

Total Members: 8,020
Newest Member: coffeeengineer

View Thread

Who is here? 1 guest(s)
 Print Thread
Am I doing something stupid TC4C+Artisan
Hello all, long time lurker first time poster,

I was hoping that those more familiar with the software and more patient than I might be able to help. I have had my setup working off my work laptop since March. . .I got laid off (not for using their laptop ;)), but I believe I was running Artisan 0.6.0. . .on that I cannot be sure. But I was definitely running REL-200 sketch in the Arduino. I have a Hottop model D with about 1700lbs through it. She keeps on ticking.

I have reloaded with the REL-300 software and have tried both 0.7.5 and the latest PID software and I am getting the same problem. At ambient, ET/BT match-ish the internal RTD measurement. But as I heat the TCs seem to roll over and I never even hit my start BT before the Hottop shuts down to protect itself. This HAS to be software, I didn't do anything but connect a different PC and update the sketch.

Would this be explained by leaving "CELSIUS" defined in user.h? Should I edit and recompile? If so, do I use "FARENHEIT" instead of "CELSIUS"?

Thank you
Edited by allenb on 10/17/2014 8:28 PM
Being the weekend it may take a little time for our TC4/Hottop gurus to chime in but hang in there and someone will get back to you. On a positive note, most folks who end up changing or reloading TC4/Arduino sketches end up being experts at it by the time all is loaded and running. It makes future tweaks or updates much easier.

1/2 lb and 1 lb drum, Siemens Sirocco fluidbed, presspot, chemex, cajun biggin brewer from the backwoods of Louisiana
Thanks Allen. I think changing my thread title to an actual question should help too. I have no choice but to be patient as I'll be traveling for awhile anyway.

I'm an EE and I'm sure given enough time and digging I can figure it out. The same can be said for a monkey though.


therabidweasel wrote:
But as I heat the TCs seem to roll over and I never even hit my start BT before the Hottop shuts down to protect itself.

What do you mean by "roll over"?

When the Hottop shuts down, is it because the OEM probe is reading a high temperature? Or is it associated with a step increase in fan speed?

Hi Jim, thank you for responding.

By "roll over" I mean that the TCs respond with a decreasing slope with increasing temperature relative to the internal RTD. I have a D model. The Hottop shuts down (eventually) due to a high reading by the RTD, whereas my TCs are still measuring too low to trigger a start in my alarms table (which is 390F). I say "decreasing slope" only because the measurements actually jive around 90F. Again, no hardware changes except the PC and it was working fine before that.

Can you confirm whether or not my user.h file can have and/or needs "FARENHEIT" instead of "CELSIUS"? This has to be software somehow, but I didn't have much time to investigate before going on the road after I chased all the demons out and got it to compile.

It is a Windows PC running XP and this was with a fresh install of Arduino software on the PC, fresh Artisan, fresh FTDI drivers, fresh 0.7.5 and PID versions of the firmware as subfolders simultaneously in the library folder during my compile(s). Fresh in this case means none of it had ever previously existed on this machine.
Fahrenheit is the default. It can be overridden by uncommenting

//define CELSIUS

Also make sure you have thermocouple type set correctly in user.h. Default is type K.

BTW, the CELSIUS compiler directive only controls the initial conditions.

Artisan sends a UNITS command to the TC4C after things start up. So perhaps you have not configured Artisan for Fahrenheit units?

The fact that the readings appear to agree at 90F makes me somewhat suspicious that Artisan is expecting/displaying Celsius readings from the TC4C (90C = 194F).

Edited by JimG on 10/22/2014 8:52 AM
Jim and others,

can anyone give me a hint where I modify artisan to send a units command of F? Nothing I have seen or done has changed the issue. I recompiled and reloaded with Celsius commented out and changed the Units string in the registry from C to F. That said, the DTA:units string in help-> settings =. I cannot figure out how to change that. My axes are labeled as F and my options under roast-> temperature are convert to Celsius and Celsius mode.
In addition to the above, I have now verified with a third TC that for whatever reason, I have Artisan and the TC4C setup such that when Artisan believes it is getting farenheit data it is actually being sent Celsius. When I set Artisan to "Celsius mode" it recalculates the incoming measurements as if they were F. That exacerbates the problem. So I know what the issue is, I just can't find any settings or information that will help me fix this. Surely someone has had this problem before? I think I need to just send the TC4C the right command at startup, but again, I'm still trying to figure out how one does that.

thanks for any help.
Wow! That sounds maddening Shock

To narrow down the problem, try talking directly to the TC4C. Do this by opening a terminal session inside the Arduino IDE. Set the baud to 115,200 (you are using aArtisan 3.00 right?), and set the line end dropdown box to "Newline."

Send these text string commands to the TC4C:

chan 1200

(You should receive an acknowledgement from the TC4C).


(Ambient temp, followed by T1 and T2 should come back)

units F

(All readings should now be F, regardless of initial conditions)

units C

(All readings should now be C).

If the TC4C responds as expected to these commands, then you can focus your efforts on the other side of the USB cable.


something seems to be out of order on your setup. Never fiddle with the registry directly! Why are you not running the latest version of Artisan which is v0.8? Anyhow, it is unlikely that something is wrong on the Artisan side as I am using it with the TC4 in C mode for years and it always worked as expected. Also the aArtisan code in Artisan did not change much during the last versions.

My suggestion is first run the tests suggested by JimG above using the Arduino app to rule out any firmware/TC4 issues.

Next, do a "Factory Reset" (under menu Help) of Artisan. Restart Artisan and do a menu "Roast" >> "Temperature" >> "Celsius Mode". Test again.

Jim and Marko, thank you for responding. Jim, I tried your suggestions at multiple temperatures and the results all appeared to be correct. I recorded temperatures as high as 480F...that approximate corresponds to 340 according to Artisan. The worst part about this problem is that I have to go back to the terrible fixed roast profile after developing some really nice profiles for my current coffees. Yuck.

Marko, I am using 0.7.5 because I thought it was the same version I may have had on my work laptop. I have no way to tell for sure, but I tried 0.8.?5? first and it showed this problem. I guess it must have been 0.6 that I had on the laptop. I set everything up just before the DCFAN stuff was released.. Even after the reset something is wrong. I can run a profile for awhile in farenheit, stop, switch it to Celsius and back and the temperature will jump up for a couple of readings and then fade down to the inaccurately low value. Which is freaking bizarre for a software problem. Because everything is transitory it is hard to put in precise numbers, but if i cycle F to C and back to F as quickly as i can the measured value will jump 40ish degrees F north and fade down within 10 seconds or so.

I need to fix this issue or roll back further because I am drinking swill at this point and it's killing me. Any ideas?


therabidweasel wrote:
I can run a profile for awhile in farenheit, stop, switch it to Celsius and back and the temperature will jump up for a couple of readings and then fade down to the inaccurately low value.

I need a more detailed description of this to understand the issue. So you did all the tests Jim proposed and the values were as expected. So the TC4 is doing what it is supposed to do in C and F mode.

Then you did a factory reset in Artisan and recorded in F and everything was fine. You stopped, switched to C and then back to F (??) and then you started the recording again (??) and then you got strange readings!?

Are you sure this is a C vs F problem!? So everything was totally fine in F mode after the factory reset? So why do you switch to C and back to F at all? I am lost.
Hi Marko, sorry for the confusion. No matter what I do the readings in Artisan are not correct. Jims tests however do appear to be correct. Yes, I did the factory reset and it did not change the behavior, which is this:

I start out in F, the readings are farther off from a separate TC and the internal RTD the higher I proceed in temperature. Say I am at mid-roast and it is off about 40F. If I then toggle to C, it converts that same low value to C properly, but it's still low. Stop and toggle back to F and the temperature makes a jump up to a more believable value, but rapidly fades back to the 40ish too low.

Is there a way to completely wash my system of Artisan, registry and all and try again? Again, I'm running XP and 0.7.5. Maybe I should try 0.6.0. Whatever I was using on the laptop did not have the extrapolation out to the future.
Can you be a little more specific about the "separate TC" and "internal RTD" readings and how and when they vary with the Artisan readings? I ask this because the internal RTD will lag significantly behind both ET and BT probes on a first roast, but will give false-high readings at the start of subsequent roasts.

Also, if the separate TC you mentioned is not placed very, very close to your probe(s) being read by Artisan, there can be very large differences in readings, 40F or more, inside the roast chamber.

The separate TC is about an inch away from my ET probe, i just shove it through the shoot, it is a cheap, small bare bead, probably Kevlar sheathed. I agree they can be very different, but the fact of the matter is with the new setup Artisan is only reading 340f from the exact same ET/BT probe queried through the arduino serial terminal 10ish seconds later at 480F.
I just reran. The first thing to note is that on the first roast from a cold start the RTD is LEADING the ET/BT and third TC that i have placed roughly between the other two. Here is a snapshot:Rtd=407, ET/BT=315, EXTRA TC=293.

At the shutdown point, RTD=425, ET/BT=330, EXTRA TC=306.
Queried through the arduino, ET/BT=500F, Queried in Celsius units, ET/BT=260.

All of the extra TC numbers are in Celsius, sorry for mixing units.

I therefore conclude that Artisan thinks it's reading C when it is set to F. Can I get an amen?
Edited by JackH on 10/31/2014 7:32 PM


therabidweasel wrote:

All of the extra TC numbers are in Celsius, sorry for mixing units.

I am now even more confused.

However on my setup, the temperatures indicated by the Hottop RTD are always of from well-placed TCs as that RTD is mostly measuring the temperature of the roasting chamber via its direct contact to the metal only partially the air/bean temperature.

Note that Artisan is not designed to switch measuring units mid roast. The UNITS command is only issued on turning Artisan ON. Therefore, switching the units is deactivated in the ON state (at least on the actual version).

My suggestion is to use some tool to uninstall Artisan, remove the Artisan registry entries completely and install the latest version of Artisan. Select the temperature unit you want to work with. Roast. Forget about those RTD values.
The extra TC is a cheap harbor freight DMM that only reads Celsius. My ET/BT are placed in the standardish locations. The last run had that TC between those two probes and tracked them well. Since it is reading Celsius(too?) I'm pretty sure now that's what Artisan is doing. As I said before, this is exactly what was happening on the first install to the machine using the latest software. I am going to remove artisan an roll everything back to 0.6 and see if that works. Maybe someone will find and fix this issue or I'll go into the code and see what is causing it to trip up at a later date.

I do indeed have to stop it to change units. Marko, can you say if any files are modified other than those in the application folder and the registry? Alternatively, can you elaborate on the "some" tool? I am currently planning to go to work on it with a blow torch and a pair of pliers.
I am not a Windows guy. So I wrote "some tool" as I guess some tool might exist to do that job. Only the registry and the App folder are touched by Artisan.

Btw. there is no need to roll back to 0.6. That code did not change between versions from 0.5 to 0.8. A quite large number of users (incl. myself) is using (or have been using) all of those version with aArtisan in C and/or F without any problems. So I am pretty sure that this is not a software issue on TC4 nor Artisan side.
Based on your comments I went ahead killed anything in the registry that said artisan and installed 0.8.0...I have the same issue. I thought that maybe plugging get the PC into the same outlet might be a problem, but removing that didn't help. I can literally touch my breaker box and the roaster at the same time, so I didn't figure it would be a problem.

One intriguing thing happened and that was when the hot top cooled down before restarting, it did not catch the 168 mark and so the clock didn't start running. When it hit 425 it was still waiting to start and therefore didn't shut down. I pushed it up until the RTD said 440 (artisan BT=344) and shut it down. I am completely clueless now. I cannot forget about the RTD, because it is shutting the roaster down while Artisan is still 100 degrees below my drop temperature. Maybe my board is going out, but that corresponding to changing the computer just seems improbable. I'm lost.
For whatever reason it is also not displaying the default buttons fo 1C start and end etc...even though those boxes are checked.
My last guess is that you have a problem with your Windows registry. Artisan stores its state, including the one which event buttons to show and the temperature mode (C/F), in this registry. If this does not work reliable on read or write, Artisan might act in quite funny ways. There must be a tool to check/validate/fix that registry.

If you use the "Factory Defaults" menu item, Artisan will ignore the registry settings on next start and use its default values. On quite of Artisan the actual settings are stored back to the registry.

Problems with any other software on that machine?
Gentlemen, my problem is solved. Marko, your assessment made perfect sense to me. So much so that I formatted the hdd and reinstalled windows, service packs, and drivers...twice. I did have some problem involving AMD processor and Intel power management drivers that was somehow being masked until the reinstall. I had also manually removed a ton of Adobe software directly from the registry of this machine 5-6 years ago before I stored it. When I finally got it all back up and running it was storing my settings (in showing the buttons etc) but I still had the same problem with the measurements tracking my Celsius meter.

The above made me reconsider the hardware change to a desktop. I never ran my laptop off a supply, always off the battery. I have ungrounded TCs, but they are shielded. Sure enough I fixed the problem by tying the roaster chassis to USB ground. Oh the humiliation! Weeks I've been trying to fix this!

Gentlmen, i express to you my deepest thanks and apologies. I had thought about this often when i was running floating on the laptop. However, in my haste to get back up and running before my travels I forgot this possibility. The fact that my measurements tracked a separate meter was a red hearing, once again proving correlation is not necessary causation. Should i meet either of you in person in the future, i owe you a beer. Marko, you can also kick me square in the giblets if you want. I deserve it.

I appreciate everyone's help. Hopefully my shame will help other people in the future. Again, Marko and Jim, I am indebted to you.
Jump to Forum:

Similar Threads

Thread Forum Replies Last Post
Unable to get Artisan Scope's PID to control heating Dataloggers/Controllers/Rate of Rise Meters 4 08/01/2023 9:11 AM
Artisan PID turns heater back on during cool down Dataloggers/Controllers/Rate of Rise Meters 2 07/03/2023 12:31 PM
Artisan Talking Alarms? ROASTING SOFTWARE APPS 4 06/10/2023 12:05 PM
can't establish communication between TC4 and Artisan Fluidbed Roaster 17 06/03/2023 9:17 PM
Looking for Artisan release v1.1.0 Dataloggers/Controllers/Rate of Rise Meters 8 06/02/2023 1:52 AM
Homeroasters Association Logo, and all Content, Images, and Icons © 2005-2016 Homeroasters Association - Logos are the property of their respective owners.
Powered by PHP-Fusion Copyright © 2023 PHP-Fusion Inc
Released as free software without warranties under GNU Affero GPL v3
Designed with by NetriX
Hosted by skpacman