Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
You must login to post a message.

03/04/2024 7:29 PM
htmlbarist Welcome

03/04/2024 3:55 AM
welcome to forum DiyDan, alin and coffin420

03/03/2024 7:22 AM
YUL MTL, wayback and jakehounds, welcome2

03/01/2024 8:52 AM
coffee drink, nguyenanh ?

02/29/2024 1:31 PM
peternh, welcome cup

In Memory Of Ginny

Latest Donations
dmccallum - 10.00
JackH - 25.00
snwcmpr - 10.00
Anonymous - 2.00
Anonymous - 5.00
Users Online
Guests Online: 7

Members Online: 0

Total Members: 8,129
Newest Member: htmlbarist

View Thread

Who is here? 1 guest(s)
 Print Thread
TC4 connect to Raspberry Pi
i have my TC4 now setup and showing a display ! :-) can anyone point me the way to set Artisan to allow it to connect to the Arduino UNO and the TC4 Shield please.. i just cant find anywhere that shows the connections.
I managed to get part of it to work via RPi but only when I start Artisan. No temp values in standby mode. Still looking for artisan settings
Config menu / Device...
Then in the dialog window check the TC4 option button, optionally change channels and filters values, then press OK.
In the next dialog choose the comm port and comm settings, speed, etc.
Finally press OK.
I think I have it set like that but had to mess with it as I didn't have a USB option to pick So i did a copy paste from another screen.. but I'll double-check that today! Thankyou
Ok weird thing, all my temps have gone to -1.0 which I think means no connection...

**UPDATE - when powered up, my LCD connected to the TC4 is showing temps and is good. BUT i cant find any documentation on setup for the Raspberry Pi to the TC4. ugh

ive now tried every connection setting i just must be doing something wrong.
Edited by NewBean on 07/13/2019 9:42 PM
OK stupid question, this is my setup

Raspberry Pi 3+ with sd loaded with Artisan / USB-A to USB-B / Arduino with aArtisanQ_PID sketch with TC4 Shield on top

could it be just

Raspberry Pi 3+ with sd loaded with Artisan (somehow with ) aArtisanQ_PID sketch with TC4 Shield on top

Here are a few pictures of the current setup https://photos.ap...Gk59mMRmK7

I have included screenshots of the settings to which im trying to connect to the TC4 from the Pi
Edited by NewBean on 07/13/2019 9:44 PM
Clear anything in the modbus tab, TC4 is not modbus device.
Also, extra device setting is not mandatory in the first phase.
The first tab, labelled ET/BT should be right, but no experience with devices under Linux.
Sorry can't help more...
Thanks for the offer, i must have my device name incorrect!
This is what i have but just wont make a connection.
It looks like you have everything connected correctly. But the serial connection isn't working. I don't recall doing anything special to get the Arduino talking to the Pi.

Did you program the Arduino from the Raspberry Pi? Just wondering if you have already had it connecting properly to the Pi in other software.

Have a look here, an old post on the Artisan-user mailing list.

A renatoa suggests, I would leave the modbus and extra devices on defaults initially.

Check that the baud rate is the same as you have set in the aArtisanQ_PID user.h file.

I'll see if I can have a look at my Artisan/Pi setup later today.


I managed to get part of it to work via RPi but only when I start Artisan. No temp values in standby mode. Still looking for artisan settings

I just re-read your earlier posts. Are you saying you did have temperatures showing in Artisan at one stage?

And temps only show once you click ON
Hi Green, well at first i didn't but then after playing for a while i managed to get the temps to show on the Artisan ( RPi) side of things but only after i clicked "ON" they would show up, not in a stand by mode.

Side Note* the temps have always been showing on the LCD screen that is connected to the TC4 :-)

Now i restarted the Artisan program a while later and I'm not able to get the temps or any control of fan of heating from the Artisan (RPi ) side at all. If i change the Heat to 50% it does not change on the TC4 LCD so that means i have no connection between the 2.

i added a few pictures in the link UP a few posts to show my config side of the Artisan
Here's my serial port settings.

After clicking ON it is essentially in standby mode. Clicking Start will start recording and graphing.
greencardigan attached the following image:
Thanks for the reply, how did you come up with the
is there a way to determine this is the correct path from the Pi as ive changed mine and no connection.

Look on the Black dashboard picture, states its unable to open the port?
NewBean attached the following images:
vncsnip1.png vncsnip2.png

Edited by NewBean on 07/14/2019 11:39 PM
I don't recall how I found it. Maybe just in the list of Com ports found by Artisan in the drop down list.

In the link I provided a few posts back it has this advice.


In terminal, by listing the content of dev folder, I observed that entry 'ttyUSB0' appears only if the Amprobe logger plugged in. I assumed this is the port name to use instead of what Artisan showed.
Put a little time into this today as far as i can dig with my skillset.
1-Confirmed Sketch is 115200
2- changed all Settings to follow /dev/ttyAMAO
3- saved setting under help
4- restarted Artisan
5- turned ON
** Dashboard cant access serial port "Scope monitoring" ( artisan LOCKS Up have to restart R-Pi to get control )
6-changed to /dev/cu.usbserial-FTFKDA5O
7- sudo chmod 666 /dev/cu.usbserial-FTFKDA5O ( no file found )
8- saved and restarted
9- Turned ON
** Dashboard cant access serial port ( artisan didnt lock up on me this time )
10-changed to /dev/cu.usbserial
11- saved and restarted
12- Turned ON
** Dashboard cant access serial port ( artisan didnt lock up on me this time )
Pictures here - https://photos.ap...t6DLQh2Ly5

How do I can within artisan to see ports that are available to it
Edited by NewBean on 07/15/2019 1:12 PM
Open a terminal window, and type lsusb, something as below should appear:


Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 039: ID 1a40:0101 Terminus Technology Inc. 4-Port HUB
Bus 001 Device 003: ID 064e;d101 Suyin Corp. Acer CrystalEye Webcam
Bus 001 Device 040: ID 04d9:1702 Holtek Semiconductor, Inc.
Bus 001 Device 041: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse

... then, another command, usb-devices, should list you a lot of data for each usb device from the list above. maybe you find this way the name of usb port where is connected TC4...
Renatoa, Thank you.. i got a list. All i have connected to the USB from the R-Pi is the TC4 and a USB dongle for the keyboard and mouse combo.

3f980000.usb is a Linux device, im using USB slots 1 & 4 (#1 is showing as DWC OTG Controller)

now how to i get "3f980000.usb" into the Artisan Port settings

NewBean attached the following images:
img_20190715_154601.jpg img_20190715_155058.jpg

Edited by NewBean on 07/15/2019 3:19 PM
Did you try to checking the dev folder on your Pi to see what file appears when you connect the Arduino?


How do I can within artisan to see ports that are available to it

There is a drop down selection list for the com port settings dialog.
greencardigan attached the following image:
Hi ya GreenC, my drop down shows only 1 port, and this is the file structure.. sorry im so bad in this area
NewBean attached the following images:
dev4.png dev3.png dev2.png portsavi.png
Well, I did a factory reset to ensure I was working on a fresh platform. I tried com1-5 and all others... still nothing.. I'm feeling defeated :-(
I see two ports in your list.


Would would just try them both but I suspect the ttyAMA0 is the correct one. note that it is a zero on the end, not a letter O.

Also, in the Pi configuration, check if Serial is enabled? See attached image.
greencardigan attached the following image:
Also, don't forget that temps will only display after clicking ON.
Try this from another forum.


I tend to be very brute force with stuff like this. I do a "ls /dev/tty*", with the device unplugged. Then plug the device in and repeat the ls command. The difference in the two lists should be your device, and usually shows up as ttyUSB0 or ttyACM0 (or in your case, may be a ttyAMA0). BTW, If you already had a serial device connected, it may be named something like ttyAMA0, so your new device would then be called ttyAMA1.
Im not sure as to what the "is /dev/tty*" means

do i just put that in the port section with the device unplugged save the settings then plug the TC4 in and then see if another option shows up?

or is this a terminal thing?
ls from list, not is, as in "he is"

To issue a list command, you have to open a terminal window:
Jump to Forum:

Similar Threads

Thread Forum Replies Last Post
Raspberry+artisan Bread Machine Roasters 8 03/08/2023 1:06 PM
Connecting a raspberry pi to artists scope: no readings... Popcorn Popper roasting 43 07/15/2021 3:12 AM
Can't get Artisan serial port to connect Dataloggers/Controllers/Rate of Rise Meters 7 07/14/2020 9:18 PM
New MacBook Air 2020 & Hottop: Can't Connect HotTop Roaster 4 07/13/2020 6:10 PM
Getting Center 301 to connect to Windows 10/Artisan Dataloggers/Controllers/Rate of Rise Meters 2 11/07/2019 6:04 PM
Homeroasters Association Logo, and all Content, Images, and Icons © 2005-2016 Homeroasters Association - Logos are the property of their respective owners.
Powered by PHP-Fusion Copyright © 2024 PHP-Fusion Inc
Released as free software without warranties under GNU Affero GPL v3
Designed with by NetriX
Hosted by skpacman