topbanner.gif
Login
Username

Password




Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
Shoutbox
You must login to post a message.

renatoa
02/27/2024 2:10 AM
Airtimid and Foolmeonce, welcome to forum

allenb
02/26/2024 5:58 PM
kinkades Welcome

allenb
02/26/2024 11:46 AM
seidler Welcome

allenb
02/25/2024 10:07 AM
majdibrahim Welcome

renatoa
02/25/2024 2:26 AM
morning, SigLover21

In Memory Of Ginny
Donations

Latest Donations
dmccallum - 10.00
JackH - 25.00
snwcmpr - 10.00
Anonymous - 2.00
Anonymous - 5.00
Users Online
Guests Online: 5

Members Online: 1
Ben N

Total Members: 8,119
Newest Member: Airtimid

View Thread

Who is here? 1 guest(s)
 Print Thread
TC4 connect to Raspberry Pi
greencardigan
I see two ports in your list.

/dev/cu.usbserial
/dev/ttyAMA0

Would would just try them both but I suspect the ttyAMA0 is the correct one. note that it is a zero on the end, not a letter O.

Also, in the Pi configuration, check if Serial is enabled? See attached image.
greencardigan attached the following image:
capture_19.png
 
greencardigan
Also, don't forget that temps will only display after clicking ON.
 
greencardigan
Try this from another forum.

Quote

I tend to be very brute force with stuff like this. I do a "ls /dev/tty*", with the device unplugged. Then plug the device in and repeat the ls command. The difference in the two lists should be your device, and usually shows up as ttyUSB0 or ttyACM0 (or in your case, may be a ttyAMA0). BTW, If you already had a serial device connected, it may be named something like ttyAMA0, so your new device would then be called ttyAMA1.
 
NewBean
Im not sure as to what the "is /dev/tty*" means

do i just put that in the port section with the device unplugged save the settings then plug the TC4 in and then see if another option shows up?

or is this a terminal thing?
 
renatoa
ls from list, not is, as in "he is"
https://en.wikipe...rg/wiki/Ls

To issue a list command, you have to open a terminal window:
https://www.raspb.../terminal/
 
NewBean
Thankyou for the teachable moment!

Pi-is configured with Serial active
i also did a few things in the terminal and i can see a few folders but can't cd/ into them but i can nano but nothing is there

Does anyone feel like a TEamView?
NewBean attached the following image:
cmd.png
 
renatoa
Can you check if any tty entry appear and disappear when issuing ls commands with TC4 connected and not ?
If you find it, then this is the serial port name.
If that port is not listed in Artisan, then this is other issue...
 
NewBean
I think i need to mention, not sure if this is a factor, Im powering the Raspberry Pi3B+ with the orig power micro USB power adaptor, then the USB over to the Arduino UNO with TC4..

should the Arduino be powered separately than piggybacking from the Pi?
 
NewBean
i just completed the LS with it unplugged and then plugged in and nothing changed in the /dev folder
 
renatoa
Please, don't raise an eyebrow, or laugh... because already happened this for me... maybe your usb cable is charging only, no data leads ? Grin
 
NewBean
LOL ive done that before ! this setup was working for 2 days with connection between the 2, but not anymore..but thanks for the tip thats overlooked allot of times
 
NewBean
Taking the plunge, removing Artisan from the Raspberry Pi 3B+ restarting, updating system, restarting and then reinstalling Artisan! fingers crossed
 
NewBean
i removed the artisan program from the Pi and then restarted and loaded it back in from the zip file, and weird thing is that the screen and settings were still all there. it was like i never removed it. this is now becoming a pain in the A$$ this fun project is now frustrating
 
NewBean
ok yep me again, just keeping whoever is following along for the ride. removed the artisan program from the terminal side of things and was removed 100% :-) then downloaded from artisan a new copy and then installed as root this time to ensure i was not getting caught up with permission issues. BUT still the same thing.. NOTHING. cant connect to the TC4 from the raspberry pi. Just told the wife im scrapping the entire project so frustrated, she didnt look too happy about that!
 
greencardigan
Could you try a different USB port on the Pi?

Other than that I'm pretty much out of ideas sorry.
 
NewBean
Yep, tried all 3. Next step is to get a new pi, new Raspbarian and start again..
 
greencardigan
One more idea. Try an older version of Artisan? I'm using 1.5 or 1.61 I think.
 
JackH

Quote

greencardigan wrote:

One more idea. Try an older version of Artisan? I'm using 1.5 or 1.61 I think.


Hi Greencardigan!
Are you using the same version PI board as NewBean?
---Jack

KKTO Roaster.
 
renatoa

Quote

NewBean wrote:

Yep, tried all 3. Next step is to get a new pi, new Raspbarian and start again..


I would test that TC4 on a PC, using same usb cable as for raspi
 
NewBean
Renatoa, well good advice, i loaded the laptop with Artisan and configured it for the tc4 and NOTHING no connection regardless what setting i put.. but the TC4 is alive as im looking at it boot up and show counter/et80/bt81/ror0/htr0/fan0
 
NewBean
Unless I'm just not doing something correct in the setup..
 
NewBean
It must or has to be how I'm setting up the port. But only com3 is showing and that does nothing, but in the other tabs I have different com numbers, yep tried them too..
 
renatoa
Alive, but not communicating, they aren't exclusive... Grin
So let the PI alone and focus on TC4 serial port, or the cable.

Check on PC the Device Manager, Ports branch, if reacting when connecting/disconnecting TC4.
 
NewBean
ok i think ive figured it out ! the Arduino UNO is CRAP.. i started from the beginning of time. tried to load the Artisan_PID sketch onto the UNO and i cant connect with it. tested the main computer and still no connection NO data connection. so back to ordering new items.
 
NewBean
OK quick question, i Purchased this UNO but its an R3, will this work with the TC4 ? or did i screw up LOL
https://www.amazo...prod_image

GreenCardian - this is the difference BUT need to know if this will be OK with your TC4, Thanks in advance
https://startinge...fferences/
 
Jump to Forum:

Similar Threads

Thread Forum Replies Last Post
Raspberry+artisan Bread Machine Roasters 8 03/08/2023 1:06 PM
Connecting a raspberry pi to artists scope: no readings... Popcorn Popper roasting 43 07/15/2021 3:12 AM
Can't get Artisan serial port to connect Dataloggers/Controllers/Rate of Rise Meters 7 07/14/2020 9:18 PM
New MacBook Air 2020 & Hottop: Can't Connect HotTop Roaster 4 07/13/2020 6:10 PM
Getting Center 301 to connect to Windows 10/Artisan Dataloggers/Controllers/Rate of Rise Meters 2 11/07/2019 6:04 PM
Homeroasters Association Logo, and all Content, Images, and Icons © 2005-2016 Homeroasters Association - Logos are the property of their respective owners.
Powered by PHP-Fusion Copyright © 2024 PHP-Fusion Inc
Released as free software without warranties under GNU Affero GPL v3
Designed with by NetriX
Hosted by skpacman