topbanner.gif
Login
Username

Password




Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
Shoutbox
You must login to post a message.

allenb
12/01/2022 11:20 AM
temkhabana Welcome

renatoa
12/01/2022 3:54 AM
coffee drink, 2old2kare

allenb
11/30/2022 4:54 PM
jeco8843 Welcome

renatoa
11/30/2022 6:27 AM
Mountainman, welcome cup

renatoa
11/28/2022 2:46 AM
Welcome, @Microfiche

In Memory Of Ginny
Donations

Latest Donations
dmccallum - 10.00
JackH - 25.00
snwcmpr - 10.00
Anonymous - 2.00
Anonymous - 5.00
Users Online
Guests Online: 8

Members Online: 1
CK

Total Members: 7,724
Newest Member: temkhabana

View Thread

Who is here? 1 guest(s)
 Print Thread
Both Manual and Digital contol?
progen
It's weird that I got a strange problem lately. During testing, everything worked fine and I could control the SSR manually via a pot and only used the light dimmer module's ZCD feature. All nice and good.

But today, whenever I turned on the light dimmer module, IO2's light will start flashing and OT1 will be outputting a signal around 30% regarding of whether the pins to the pot are plugged in or not. The setup is also not responding to the pot.

It's fine when I comment out the Analogue 1 line in user.h but the problem comes back when I comment in Analogue 1 again.
 
renatoa
Check your pot integrity.
Is the cursor (middle pin) voltage changing according to rotation ?
 
progen

Quote

renatoa wrote:

Check your pot integrity.
Is the cursor (middle pin) voltage changing according to rotation ?


The thing is I get this problem the very moment I activate Analogue 1 in user.h even if the pot is not connected. All 3 pins unplugged. It starts the moment I turn on the light dimmer module.
 
progen
If I recall correctly, Devices in Artisan Scope should be Arduino 5/6 and 7/8. I don't know why mine because 3/4 and 5/6 but should Artisan settings influence the Arduino / TC4+ even when the software isn't running?

Anyway, what I did was reset Devices, Extra Devices and added back Arduino 5/6 and Arduino 7/8 and now it works fine.

Guess this is one of those little glitches that once you've encountered it before, you never worry if you see it again.
 
progen
Damn, spoke too soon. Problem came back. At 3.3V, I can only go up to 68% on the heater but at 5V, I can go up to a full 100%. All working fine during testing but it's giving me problems when I'm using the 5V. When I go back down to 3.3V and reset everything, it's fine.
 
progen
Sorry for the false alarm. It seems that bending the pot's pins to the TC4+ solved all of the problems.
 
Jump to Forum:

Similar Threads

Thread Forum Replies Last Post
Manual traditional grinder GRINDERS 3 12/05/2021 6:40 AM
Roast Profiles for Behmor 1600 Plus - Manual Mode Roasting Profiles 3 01/01/2020 12:03 PM
Australian subtropical coffee grower?s manual Growing Coffee 4 03/23/2019 12:39 AM
Roast Profiles - For Behmor 1600 Plus Manual Mode Behmor 1600 9 08/16/2018 4:51 AM
Kaldi Wide add on: digital temp probe Other Roasters 5 03/09/2018 2:55 PM
Homeroasters Association Logo, and all Content, Images, and Icons © 2005-2016 Homeroasters Association - Logos are the property of their respective owners.
Powered by PHP-Fusion Copyright © 2022 PHP-Fusion Inc
Released as free software without warranties under GNU Affero GPL v3
Designed with by NetriX
Hosted by skpacman