topbanner.gif
Login
Username

Password




Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
Shoutbox
You must login to post a message.

allenb
04/23/2024 7:01 PM
Paul Kalb Welcome

renatoa
04/23/2024 4:34 AM
Coffee_Rabbit_Hole
and Michaelion, welcome cup

renatoa
04/21/2024 2:35 AM
compactjack and GreenGenie coffee drink ?

allenb
04/19/2024 8:27 AM
eximwind Welcome

renatoa
04/18/2024 12:36 AM
bijurexim, greyberry2, N C, welcome2

In Memory Of Ginny
Donations

Latest Donations
dmccallum - 10.00
JackH - 25.00
snwcmpr - 10.00
Anonymous - 2.00
Anonymous - 5.00
Users Online
Guests Online: 2

Members Online: 0

Total Members: 8,223
Newest Member: Paul Kalb

View Thread

Who is here? 1 guest(s)
 Print Thread
No heat suddenly. Problem continues even with swapped heating element.
rgiaquinta
My Gene Cafe stopped blowing heat mid roast. I saw a lightbulb on the same circuit flicker right when the unit stopped producing hot air. I tried to troubleshoot by swapping out the heating element, but still don't get even the slightest bit of heat. I'm wondering what else in the unit might have fried to cause this problem?

History and deeper detail: I've used the unit about every other day for over a decade, and I've replaced heating elements several times (every few years) when I notice they aren't hitting high temperatures and my roasts begin to take a lot longer. I've also replaced the fan, bearings and several other parts, so I do know a bit about the internals and maintenance. All other parts (fan, motor) seem to be working properly, and it does not throw an error code. I don't know much about a multimeter, but I did check to see if the fuse was working (I think it is... at least it showed a continuous circuit with .1 resistance... I think). Also, I checked the current heating element along with two older ones (both of which I took out of service b/c they were causing longer roasts/lower temps, but still were getting up above 300F) and all of them showed about 11 ohm resistance between the wires that connect to the circuit board. The roaster was working absolutely perfectly up until this roast, which had gotten about halfway through, and then the temperature just started drastically falling (just after the lightbulb flickered, which caused me to worry, which caused me to watch the roaster carefully, which caused me to notice the temp dropping). I always stand by my roaster while it's on, so I do know the typical behavior quite well, and this is the only time that this has ever happened.

I'd be so happy with any feedback... I love this roaster and it has served me well!

Thanks in advance,
Robert
 
renatoa
Serviced a Gene unit recently, with broken heater wire, was a repair, not a replacement, heater unit can't be found today to match the first units on market, about 11 years ago.
The real reason of overheating was the clogged dust sieve on the bottom, under the heater turbine.
Is mandatory to vacuum there every some months... what I found there can't be described... chaff fine as a flour, solidified as concrete.

In your case I would check the relay controlling the heater.
Is the electronics still powered, i.e. display lit, wheels operating, timer counting ?
 
rgiaquinta
Yes, absolutely everything else is working as normal. It's just blowing room temperature air.

I do clean out the air filter regularly, and I removed the fan and cleaned it out about 6 months ago, and it's blowing strongly. I do agree that the filter is a good place to start troubleshooting; after about a decade of use, I found my screen clogged up with very fine sediment, causing slow roasts, so I replaced it and the problem was solved.

Thanks for the suggestion, I'll do a search about how to check the heater relay (I know nothing at all about how to do this -- yet), but if anyone might be able to steer me toward a good resource on this topic, it would be appreciated.
 
renatoa
It's the smaller plate on the back, near the fuse socket.
https://genecafeu.../power-pcb

The big black item is the relay.
The small white plug on the left side is relay control, there you should measure the 12V command, to close the relay contacts.
Missing 12V in that plug means no control from electronics/intelligence.

If control is OK, then check the contacts as in the diagram/picture below.
Checklist: PCB traces and solderings, contacts status, you should read zero and infinite on the two paths.
renatoa attached the following image:
41225-198-1.jpg

Edited by renatoa on 04/20/2023 12:14 PM
 
rgiaquinta
Thanks so much for the detailed info! I'll see what I can figure out and post back here in a few days.
 
michele
I can confirm parts and some help here:

https://genecafeu...cafe-parts

They are the only source I am aware of.

I have success contacting them via their form for Q&A. I have a 2012 roaster. Be sure to tell them that in your messages, as the older parts are available but might need "another" part. I have replaced the heater, gear, motor, ceramic bearings, chamber, and they are very responsive to emails and will offer ideas about what parts might need replacing. They are the only US source I am aware of.

I am currently in email convo with them about my relay/transformer. My issue is the temp stops advancing at a temp less than set, then kicks in again, and rises off and on, cycling on and off, rising to the set temp. This is inconsistent of course and could have been due to a lot of chaff in the chamber not clearing into the chaff collector. We are thinking it's the transformer or inlet temp.

Hope this helps you,
Michele
Edited by renatoa on 04/30/2023 2:25 PM
Gene Cafe ca. 2012 (red one!) with lots of replacement parts, Encore Baratza, Clever Dripper, Aeropress, Melitta dripper, Yama siphon, French press
 
rgiaquinta
Renatoa, thanks so much for the diagram and for your time. I think it helped me find an issue... On the underside of that relay, it looks like there's a bad solder joint (see photos - in "top" it's the topmost joint in the photo - near center, and in "side" it's the joint closest to the middle of the photo). If I measure resistance from that pin to the solder on the circuit board where it should be attached, I'm getting "Open Loop". There appears to be an air gap around the circumference of the pin, where there is no solder connecting it to the circuit. The entire "joint" looks discolored and rough. Thus, it seems that the relay has no connection to the heating element. So my guess is that I should either try re-soldering, or just order a new relay board? Any suggestions? I wonder if this is just a symptom of a larger problem... ie, why did that joint get hot enough to fry?

Before finding this, I took the readings that you suggested, and I'll include them here in case they add any useful info: I took voltage readings at the relay control connector (see "roaster edited" picture attached -- I tested the wires at the white harness indicated by arrow circle). While the unit was running in heat mode, I read 17.5 ; in cooling mode it read about 20 ; when powered on but not running (stop mode) 30. Given my rudimentary understanding of electronics, I don't know how to interpret this and would appreciate any input.

Michele, thanks for the contact info; I've purchased many parts from that site, and I guess if I can't get things figured out via this forum, I will contact them.
rgiaquinta attached the following images:
top_2.jpg side_3.jpg roaster_edited.jpg
 
renatoa
I would try re-soldering first.
Could be a bad solder from the factory, maybe that relay pin was not properly coated with alloy.
Search "tin pest" for more info about this process in soldering alloys using Stannum (tin)

If no soldering tools available, go with the board to a cell phone service shop.

The control voltage sounds suspicious to me, 30V in stop state is ludicrous... Shock
I am not aware about 30V available anywhere inside Gene, the mains transformer delivers about 18V, that are regulated down to 12V for the electronics, as far as I remember...
You can check the transformer output voltage on the highlighted white plug, and the regulated 12V on the highlighted capacitor.
Anyway, a wrong control voltage can't led to that solder rust, definitely... they are not related at all.
renatoa attached the following image:
roaster_edited_1.jpg

Edited by renatoa on 05/01/2023 1:24 PM
 
rgiaquinta
Problem solved!!! Resoldering the relay connection worked (see attached figure - I re-soldered the joint closest to the middle of the photo). The heat now cycles on, so the heater relay must have been remaining an open circuit because the relay was not getting the signal to close the circuit.

Thanks renatoa for steering me in the right direction. I'm not sure what was wrong with my voltage readings, but they are irrelevant at this point; I'll chalk it up to my inexperience with using the multimeter.

If anyone else has a similar problem but does not want to do the soldering, the relay/power board is available at the link in this thread, and is relatively cheap. If you can solder, though, it's a one minute, simple fix.

So happy to be drinking good coffee again!
rgiaquinta attached the following image:
fixed_solder.jpeg
 
Jump to Forum:

Similar Threads

Thread Forum Replies Last Post
Heat gun flour sifter roaster Heat Gun Roasting 1 01/06/2024 8:42 AM
Another heat gun bread machine roaster Heat Gun Roasting 2 01/03/2024 4:10 AM
Larry Cotton's 'wobble disc' heat gun build Heat Gun Roasting 63 11/19/2023 9:25 AM
Renatoa can you walk us through a roast based on Heat power control vs PID? Roasting Coffee 32 08/21/2023 12:41 AM
Unable to get Artisan Scope's PID to control heating Dataloggers/Controllers/Rate of Rise Meters 4 08/01/2023 9:11 AM
Homeroasters Association Logo, and all Content, Images, and Icons © 2005-2016 Homeroasters Association - Logos are the property of their respective owners.
Powered by PHP-Fusion Copyright © 2024 PHP-Fusion Inc
Released as free software without warranties under GNU Affero GPL v3
Designed with by NetriX
Hosted by skpacman